USB Wifi Adapter Installation on the BeagleBone Black

USB Wifi Adapter Installation on the BeagleBone Black

USB Wifi Adapter Installation on the BeagleBone Black

USB Wifi Adapter Installation on the BeagleBone Black

We’ve had such a passionate response to our original BeagleBone WiFi installation tutorial that we’ve created updated instructions and troubleshooting tips for the latest Linux Debian release. You can find the updated tutorial here.

The Logic Supply UWN100 and UWN200 Compact USB Wifi Adapters are great for use with the BeagleBone Black. These adapters are based on the relatively new Ralink/MediaTek MT7601 chipset, so drivers are not widely available yet. This tutorial provides step-by-step instructions for downloading and installing the drivers.

Tutorial: Compact USB Wifi Adapter Installation on the BeagleBone Black

Find out more about the current state of BeagleBone development: New Embest Board Opens the Door for BeagleBone Black Projects

Comments (26)

  1. Teis Draiby
    October 7, 2013

    To create a wireless hotspot with the BeagleBone Black, a wifi adapter that supports “Access Point” mode is required (see

    Does the MT7601 chipset support the Access Point mode?

    thanks, Teis

  2. Roland Groeneveld
    Roland Groeneveld
    October 9, 2013

    Yes, the Mediatek 7601U chipset supports Access Point mode. We haven’t tested it but it should be possible to make it work. The latest driver can be downloaded from the Mediatek website.

  3. Teis Draiby
    October 9, 2013

    Thanks, great. Order placed.

  4. Adam
    December 18, 2013

    I cannot get the installation instructions to work (either method) on the latest Angstrom distribution on a BeagleBone Black. Any modifications to the procedure? I have the latest driver from the Mediatek site downloaded. Thanks!

  5. Roland Groeneveld
    Roland Groeneveld
    January 10, 2014

    Hi Adam,

    The latest Angstrom distribution already has the drivers for the UWN100 and UWN200 loaded in the image by default. So you should not need to install the drivers again. Hope this helps.

  6. Adriana
    January 21, 2014

    Hello, i cant get mine to work i was able to do all the steps but when i disconnect the ethernet and im going to test it it doesnt tell me i have internet connection.

  7. Roland Groeneveld
    Roland Groeneveld
    January 22, 2014

    If you followed the instructions and it still does not work, it likely is a problem with Wifi security (encryption settings, passphrase, etc) . You may want to test with a different Wifi Access Point, preferably with a straightforward SSID and passphrase.

  8. Rushi Desai
    February 5, 2014

    Is there any plan to get this driver into mainline kernel? Also, has anyone built this for Debian 7.2?

  9. laborer
    March 9, 2014


    Link is broken. And I can’t find MT7601 product on Mediatek site

  10. Roland Groeneveld
    Roland Groeneveld
    March 10, 2014

    Thank you for pointing this out. MediaTek recently changed their website. Here is the new link: – search for MT7601U for the linux driver.

    We also fixed the link in the tutorial.

  11. Colin Bester
    April 30, 2014

    I was wondering if anyone has uwn100/200 working as AP on beaglebone black with debian OS – I’d sure appreciate some assistance in getting this working.


  12. Craig Johnson
    May 18, 2014

    I am interested in buying the UWN200 for my beaglebone black, however I would like to know if it will support ubuntu 12.04. The tutorial is for angstrom as well as debian, however it doesnt mention ubuntu 12.04. I know the two are very similar but i thought it would be worth asking. So my question is will it work with the same instructions as on the tutorial or should i look for another?

  13. May 20, 2014

    Hi Craig,

    As you’ve seen, we have only tested on the Angstrom and Debian distributions (I have also installed it on Ubuntu 13.10, on an x86 system, though). That said, since the source files for the drivers are available, I am fairly confident it will be possible to get it working.

    Here is a link to a post of someone who was successful with it:!topic/beagleboard/Wbyte4qg-ZQ

  14. Josue
    May 22, 2014

    Hi I am trying to install it on my Beaglebone under Debian but I need some help. After the “make all” I get no errors but, there are no MODULE, UTIL or NETIF directories.

    To get it to compile I had to download “linux-headers-3.8.13-bone40_1.0precise_armhf.deb” from instead of kernel-dev since apt-get couldn’t find it. I also had to comment out the include directive in timex.h because there is no mach/timex.h.

    Actually I found mt7601Usta.ko in os/linux/ and used it and it works. I can connect to wifi. My problem is that I am trying to set it up as an access point and it says that the driver is invalid so I guessed that to get it to work I should use one of the others (netif or util).

    Thank you for your help.

  15. May 22, 2014


    The driver would need to be compiled with AP mode support. I have not tested or tried that, so I can’t say if that is easy or possible. Might be as easy as editing the config file to include that support, but probably not.

  16. Heiko Goes
    July 7, 2014

    I would like to use the uwn100 as a access-point on my beaglebone black Debian.
    Unfortunately hostapd complains of a missing driver. I looked at the internet, but found no solution; only people with the same problem. What am I to do?
    P.S. The adapter works well for connecting to other access-points.

  17. July 10, 2014


    As mentioned above, the driver that is included does not have AP support built in. Unfortunately, we don’t have any further information on whether it will work or not.

  18. Perry Engle
    August 25, 2014

    I don’t have a BB serial cable, I usually use a combined wireless USB keyboard/mouse. Will a powered USB hub allow a USB keyboard mouse and the UWN100 for initial configuration?

    Alternatively, I already have the serial cape on the Beagleboard, could use a Cisco serial cable to attach to it, or is that making things more difficult?

    Perry Engle

  19. Darek Fanton
    Darek Fanton
    August 25, 2014

    Hi Perry, thanks for the comment. We would recommend utilizing the supplied USB cable and using SSH to access the beaglebone. You can read our SSH tutorial on our BeagleBone resource site Inspire by clicking here – Feel free to comment on Inspire if you have any other questions.

  20. andy
    September 14, 2014

    I have followed your instructions to get the usb wifi adaptor running on the beaglebone black.
    ever things works as per your instructions apart from the wifi adaptor getting a ip address.
    I have checked the router is running wap2-spk and it is. the drivers all show on the beagle bone.
    I have check the wifi adaptor on my windows pc and it all works fine but I can not get it to work on the beaglebone black. have you got any ideas were I am going wrong.


  21. Richard
    September 15, 2014


    A common cause of not getting an ip address is “incorrect” password. (do not use quotes, correctly dealing with spaces in the pass-phrase, upper/lower case etc). Which operating system are you using?

  22. Balan
    September 27, 2014

    I managed to install the driver (MediaTek MT7601Usta) and able to connect to my home WIFI.

    but i am unable to start my Hostapd

    $sudo hostapd -d /etc/hostapd/hostapd.conf

    throws erorr as

    nl80211: ‘nl80211’ generic netlink not found


    Bus 001 Device 004: ID 148f:7601 Ralink Technology, Corp.

    $ modinfo mt7601Usta
    filename: /lib/modules/3.12.28+/kernel/drivers/net/wireless/mt7601Usta.ko
    description: RT2870 Wireless Lan Linux Driver
    author: Paul Lin
    license: GPL
    srcversion: 1E53BFE8C54FE50457C6BA7
    alias: usb:v148Fp7601d*dc*dsc*dp*ic*isc*ip*in*
    alias: usb:v148Fp6370d*dc*dsc*dp*ic*isc*ip*in*
    alias: usb:v148Fp7650d*dc*dsc*dp*ic*isc*ip*in*
    vermagic: 3.12.28 preempt mod_unload modversions ARMv6
    parm: mac:rt28xx: wireless mac addr (charp)

    $ iw list
    nl80211 not found.

  23. Darek Fanton
    Darek Fanton
    September 29, 2014

    Hi Balan, it would be useful to know which OS you’re working with? You may also find answers from members of the community on our BeagleBone resource site Inspire, where we have individual tutorials for Debian, Angstrom and Ubuntu –

  24. pucky
    October 19, 2014

    I’ve got debian installed onto my beagleboard rev C and I’m trying to use the UWN200 as my wifi adapter. I’m trying to configure hostapd as a hotspot like others seem to be in this thread. Darek, can you explain how to get this adapter (UWN200) to work with hostapd?

    my issue is the same as BALAN.
    nl80211 not found.

    is this product (UWN200) capable of being used as a hotspot?

  25. Richard
    October 20, 2014

    As compiled the UWM100/UWN200 driver does not support creating a Hostspot with this adapter.

  26. January 4, 2015

    I have same issues with this USB WiFi dongle. My RPi working fine as client but no master mode (act as access point). Maybe I can use some alternative drivers for Linux, replace original MT7601? Thanks in adv for any hints! 😉

Leave a Comment

Your email address will not be published.